renovateyourworld.com > Ask a Question > Fix It Forum > Intertherm MAC 1378 Furnace
Login | Register

Intertherm MAC 1378 Furnace


Posted by Jeff Wilson on December 26th, 2002 12:05 PM
In reply to Intertherm Furnace by David Callihoo on October 23rd, 2002 02:53 PM [Go to top of thread]

2 of 2 people found this post helpful

I have a Intertherm Furnace, Model MAC 1378 (gas).
The problem I'm having is the burner motor will run but the burner never comes on. I have checked the pilot light and it is on and burning fine.

I cleaned and restarted the furnace at the beging of fall to make sure it was in working order as I do every year. I had the same problem then when I restated the furnace. I thought the problem was the burner motor not turning enough rpms to trip the burner control (it's an old motor 1975). No clicking noise as the motor speeds up.
I cleaned the burner motor with contact cleaner to clean the brushes and this fixed the problem. The motor speeds up fine and you can hear it trip the burner control (a click noise). The furnace worked fine till this morning. The burner motor comes on and speeds up like alway and you hear the click as the burner control trips but the burner never comes on.
On top of the burner motor it has a: Simicon Solid State Power Gas Control, Model SBC-10.

What could be the problem causing this? The two places I have talked to say they will come check it out but they can't get parts for it and I will more than likely have to replace the furnace.

Was this post helpful? Yes: or No:

Topic History:

Topic Follow-ups:





About  | FAQ  | Contact  | Sitemap  | Privacy Policy  | Terms of Use  | Help

© 2014 Renovate Your World LLC