> Ask a Question > Fix It Forum > dishwasher timer stuck
Login | Register

dishwasher timer stuck

Posted by Bob on February 24th, 2003 10:31 PM

1 of 1 people found this post helpful

Have a GE Potscrubber 1430 - 7 years old. The timer knob will not move on its own when placed in the "start" position. Nudging it sometimes worked, but most of the time did not. I replaced the timer and it worked great for 4 or 5 days. It is now back to its old tricks. What else could cause this problem? I read that some dishwashers have an sensor that holds the timer until the water heats up to a certain temp. Not sure if this one has that feature, but I do know that the water seems plenty hot (based on the steam factor).

A service call and hundred bucks in parts is more than the cost of a new DW. I'd like to attempt this myself.

Any help would be appreciated.



Was this post helpful? Yes: or No:

Topic Follow-ups:

About  | FAQ  | Contact  | Sitemap  | Privacy Policy  | Terms of Use  | Help

© 2016 Renovate Your World LLC