> Ask a Question > Fix It Forum > Arcoaire
Login | Register


Posted by Pete on December 9th, 2002 09:24 AM
In reply to New HVAC forum; click on open forum by James Darrel on August 31st, 2002 11:31 AM [Go to top of thread]

0 of 1 people found this post helpful

I have an Arcoaire furnace model #GUI075A012AIN that's about 9 years old and had 2 different HVAC guys over to look at my problem. The problem is the blower is kicking on for about 30 seconds then the ignitor kicks on and the flame is lit. The flame stays on for about 10 seconds and then the whole unit just shuts down. I notice that the diagnostic indicator flashes 6 times and according to the chart near the indicator, a continuous flash (i'm assuming 6) says "Flame Sensed with No call for heat." It also says on the chart that this is an External Failure Mode. This cycle repeats itself a few times and then will either shut off for a while or eventually kick on and actually work properly. I have a programable thermostat and discontected it (hotwired it) and found out that it is not my problem. I also changed my ignitor and thermostat in the furnace itself and although this helped for a little bit, it still goes back to the same problem. I also regularly change my filter and clean the unit. This is driving me nuts because I hear the furnace constantly going on and off. No one I've talked to so far can find the problem. Any help would be greatly appreciated.

Was this post helpful? Yes: or No:

Topic History:

Topic Follow-ups:

About  | FAQ  | Contact  | Sitemap  | Privacy Policy  | Terms of Use  | Help

© 2016 Renovate Your World LLC